Investigating performance degradation

Incident Report for TeamDynamix

Resolved

Confirmed as resolved, no further issues have risen since the stability changes were made.
Posted Sep 09, 2026 - 12:32 EDT

Monitoring

Performance appears to have fully returned to normal, however we will continue monitoring to ensure it remains stable.

The root cause was a configuration change that had unintended side effects, which was quickly reversed.
Posted Sep 09, 2026 - 11:31 EDT

Investigating

We are actively investigating reports of performance degradation across Work Management the iPaaS platforms.
Posted Sep 09, 2026 - 11:24 EDT
This incident affected: East US - iPaaS (Web Interface), East US - Conversational AI (Web Interface), and East US - Work Management (Web Interface).